Commit 143b8ad3 authored by Dr. Felix Tobias Schindler's avatar Dr. Felix Tobias Schindler
Browse files

[config] let warning correspond to check

parent be1af46d
Pipeline #105597 passed with stages
in 36 minutes and 41 seconds
......@@ -43,18 +43,18 @@ def _get_dunegdt_version():
try:
version = dune.gdt.__version__
if parse(version) < parse('2021.1.2') or parse(version) >= parse('2021.2'):
warnings.warn(f'dune-gdt bindings have been tested for version 2021.1.2 '
warnings.warn(f'dune-gdt bindings have been tested for version 2021.1.x (x >= 2) '
'(installed: {dune.gdt.__version__}).')
except AttributeError:
warnings.warn('dune-gdt bindings have been tested for version 2021.1.2 '
warnings.warn('dune-gdt bindings have been tested for version 2021.1.x (x >= 2) '
'(installed: unknown older than 2021.1.2).')
try:
xt_version = dune.xt.__version__
if parse(xt_version) < parse('2021.1.2') or parse(xt_version) >= parse('2021.2'):
warnings.warn(f'dune-gdt bindings have been tested for dune-xt 2021.1.2 '
warnings.warn(f'dune-gdt bindings have been tested for dune-xt 2021.1.x (x >= 2) '
'(installed: {dune.xt.__version__}).')
except AttributeError:
warnings.warn('dune-gdt bindings have been tested for dune-xt version 2021.1.2 '
warnings.warn('dune-gdt bindings have been tested for dune-xt version 2021.1.x (x >= 2) '
'(installed: unknown older than 2021.1.2).')
return version
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment