Commit 1eb4d18c authored by René Fritze's avatar René Fritze Committed by René Fritze
Browse files

[deps] bump hypothesis to 6.52.3

parent a0b12591
......@@ -23,8 +23,8 @@ stages:
when: never
- when: on_success
variables:
PYPI_MIRROR_TAG: 27853dfb71f21547e3dfa0737ced3096420c425f
CI_IMAGE_TAG: 27853dfb71f21547e3dfa0737ced3096420c425f
PYPI_MIRROR_TAG: 9382dd473883b0db4d4b88d71467802052cdc58a
CI_IMAGE_TAG: 9382dd473883b0db4d4b88d71467802052cdc58a
PYMOR_HYPOTHESIS_PROFILE: ci
PYMOR_PYTEST_EXTRA: ""
BINDERIMAGE: ${CI_REGISTRY_IMAGE}/binder:${CI_COMMIT_REF_SLUG}
......
......@@ -2,8 +2,8 @@ DOCKER_BASE_PYTHON=3.9
PYMOR_TEST_SCRIPT=vanilla
PYPI_MIRROR=stable
PYMOR_TEST_OS=debian-buster
PYPI_MIRROR_TAG=27853dfb71f21547e3dfa0737ced3096420c425f
CI_IMAGE_TAG=27853dfb71f21547e3dfa0737ced3096420c425f
PYPI_MIRROR_TAG=9382dd473883b0db4d4b88d71467802052cdc58a
CI_IMAGE_TAG=9382dd473883b0db4d4b88d71467802052cdc58a
PYMOR_HYPOTHESIS_PROFILE=dev
PYMOR_PYTEST_EXTRA=--lf
......@@ -39,7 +39,7 @@ def setup_requires():
# recheck if jupyter_client pin still necessary
# https://github.com/jupyter-widgets/pythreejs/issues/366
# Qt bindings selectors are a woraround for https://bugreports.qt.io/browse/QTBUG-88688
install_requires = ['qtpy!=2.0.0', 'packaging', 'diskcache', 'typer', 'click'] + _numpy_scipy()
install_requires = ['qtpy>2.0', 'packaging', 'diskcache', 'typer', 'click'] + _numpy_scipy()
install_suggests = {
'ipython>=5.0': 'an enhanced interactive python shell',
'ipyparallel>=6.2.5': 'required for pymor.parallel.ipython',
......@@ -70,7 +70,7 @@ ci_requires = ['check-manifest==0.48',
'docutils==0.18.1',
'flake8-docstrings==1.6.0',
'flake8-rst-docstrings==0.2.6',
'hypothesis[numpy,pytest]==6.48.2',
'hypothesis[numpy,pytest]==6.52.3',
'pybind11==2.9.2',
'pypi-oldest-requirements==2021.2.0',
'pyqt5-qt5==5.15.2',
......
......@@ -6,7 +6,7 @@ codecov==2.1.12
docutils==0.18.1
flake8-docstrings==1.6.0
flake8-rst-docstrings==0.2.6
hypothesis[numpy,pytest]==6.48.2
hypothesis[numpy,pytest]==6.52.3
pybind11==2.9.2
pypi-oldest-requirements==2021.2.0
pyqt5-qt5==5.15.2
......
......@@ -31,7 +31,7 @@ pyopengl
pytest==7.1.2
python-slugify
pythreejs
qtpy!=2.0.0
qtpy>2.0
scipy>=1.3.3;python_version == "3.8"
scipy>=1.3;python_version < "3.8"
scipy>=1.5.4;python_version >= "3.9"
......
......@@ -5,7 +5,7 @@ numpy>=1.17.5,<1.24;python_version == "3.8"
numpy>=1.19.4,<1.24;python_version >= "3.9"
packaging
pytest-runner>=2.9
qtpy!=2.0.0
qtpy>2.0
scipy>=1.3.3;python_version == "3.8"
scipy>=1.3;python_version < "3.8"
scipy>=1.5.4;python_version >= "3.9"
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment