Commit 5084bc1b authored by René Fritze's avatar René Fritze
Browse files

[config] bump supported dune versions

parent a0a0bf0b
......@@ -45,20 +45,20 @@ def _get_dunegdt_version():
version = 'outdated'
try:
version = dune.gdt.__version__
if parse(version) < parse('2021.1.2') or parse(version) >= parse('2021.2'):
warnings.warn('dune-gdt bindings have been tested for version 2021.1.x (x >= 2) '
if parse(version) < parse('2021.1.2') or parse(version) >= parse('2022.2'):
warnings.warn('dune-gdt bindings have been tested for version 2022.1.x (x >= 1) '
f'(installed: {dune.gdt.__version__}).')
except AttributeError:
warnings.warn('dune-gdt bindings have been tested for version 2021.1.x (x >= 2) '
'(installed: unknown older than 2021.1.2).')
warnings.warn('dune-gdt bindings have been tested for version 2022.1.x (x >= 1) '
'(installed: unknown older than 2022.1.1).')
try:
xt_version = dune.xt.__version__
if parse(xt_version) < parse('2021.1.2') or parse(xt_version) >= parse('2021.2'):
warnings.warn('dune-gdt bindings have been tested for dune-xt 2021.1.x (x >= 2) '
if parse(xt_version) < parse('2021.1.2') or parse(xt_version) >= parse('2022.2'):
warnings.warn('dune-gdt bindings have been tested for dune-xt 2022.1.x (x >= 4) '
f'(installed: {dune.xt.__version__}).')
except AttributeError:
warnings.warn('dune-gdt bindings have been tested for dune-xt version 2021.1.x (x >= 2) '
'(installed: unknown older than 2021.1.2).')
warnings.warn('dune-gdt bindings have been tested for dune-xt version 2022.1.x (x >= 4) '
'(installed: unknown older than 2022.1.4).')
return version
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment