Unverified Commit 546f5580 authored by René Fritze's avatar René Fritze
Browse files

[ci] fix pybind11 setup

pybind11 is no longer installed from source in the CI images,
but rather via pypi wheel.
This requires some additional config for cmake to find the headers, etc.
parent f2f9031d
......@@ -9,6 +9,7 @@ fi
export PYTHONPATH_PRE=${PYTHONPATH}
export PYTHONPATH=${CI_PROJECT_DIR}/src:${PYTHONPATH}
export PATH=~/.local/bin:${PATH}
export PYBIND11_DIR=$(python3 -c "import sysconfig; print(sysconfig.get_path('purelib'))")
export PYMOR_ROOT="$(cd "$(dirname ${BASH_SOURCE[0]})" ; cd ../../ ; pwd -P )"
cd "${PYMOR_ROOT}"
......
......@@ -69,7 +69,7 @@ doc_requires = ['sphinx>=3.4', 'matplotlib', _PYSIDE, 'ipyparallel>=6.2.5', 'pyt
'sphinxcontrib-bibtex', 'sphinx-autoapi>=1.8', 'myst-nb'] + install_requires
ci_requires = [_PYTEST, 'pytest-cov', 'pytest-xdist', 'check-manifest', 'nbconvert', 'pytest-parallel',
'readme_renderer[md]', 'rstcheck', 'codecov', 'twine', 'pytest-memprof',
'flake8-rst-docstrings', 'flake8-docstrings', 'pytest-datadir',
'flake8-rst-docstrings', 'flake8-docstrings', 'pytest-datadir', 'pybind11',
'docutils', "pypi-oldest-requirements>=2021.2", 'hypothesis[numpy,pytest]>=5.19',
'PyQt5!=5.15.2,>5.7,!=5.15.2.*,!=5.15.4,!=5.15.3']
import_names = {
......
......@@ -8,6 +8,7 @@ flake8-docstrings
flake8-rst-docstrings
hypothesis[numpy,pytest]>=5.19
nbconvert
pybind11
pypi-oldest-requirements>=2021.2
pytest-cov
pytest-datadir
......
......@@ -2,7 +2,8 @@ cmake_minimum_required(VERSION 3.1)
project(minimal-cpp-demo)
find_package(pybind11 CONFIG REQUIRED)
find_package(pybind11 CONFIG REQUIRED HINTS ${PYBIND11_DIR} ${PYBIND11_ROOT}
$ENV{PYBIND11_DIR} $ENV{PYBIND11_ROOT})
message(STATUS "Found pybind11 v${pybind11_VERSION}: ${pybind11_INCLUDE_DIRS}")
# Create an extension module
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment