Commit 77475aa1 authored by René Fritze's avatar René Fritze
Browse files

[deps] pin ipywidgets as a workaround for #1717

parent b8f72976
......@@ -23,8 +23,8 @@ stages:
when: never
- when: on_success
variables:
PYPI_MIRROR_TAG: 967495c8d78625ff23d042d61d29a5a24ad9e761
CI_IMAGE_TAG: 967495c8d78625ff23d042d61d29a5a24ad9e761
PYPI_MIRROR_TAG: 0fdb4dd6c96a5f3861a43bc793462c1c49727114
CI_IMAGE_TAG: 0fdb4dd6c96a5f3861a43bc793462c1c49727114
PYMOR_HYPOTHESIS_PROFILE: ci
PYMOR_PYTEST_EXTRA: ""
BINDERIMAGE: ${CI_REGISTRY_IMAGE}/binder:${CI_COMMIT_REF_SLUG}
......
......@@ -2,8 +2,8 @@ DOCKER_BASE_PYTHON=3.9
PYMOR_TEST_SCRIPT=vanilla
PYPI_MIRROR=stable
PYMOR_TEST_OS=debian-buster
PYPI_MIRROR_TAG=967495c8d78625ff23d042d61d29a5a24ad9e761
CI_IMAGE_TAG=967495c8d78625ff23d042d61d29a5a24ad9e761
PYPI_MIRROR_TAG=0fdb4dd6c96a5f3861a43bc793462c1c49727114
CI_IMAGE_TAG=0fdb4dd6c96a5f3861a43bc793462c1c49727114
PYMOR_HYPOTHESIS_PROFILE=dev
PYMOR_PYTEST_EXTRA=--lf
......@@ -39,6 +39,7 @@ def setup_requires():
# recheck if jupyter_client pin still necessary
# https://github.com/jupyter-widgets/pythreejs/issues/366
# Qt bindings selectors are a woraround for https://bugreports.qt.io/browse/QTBUG-88688
# ipywidget pin is due to https://github.com/pymor/pymor/issues/1717
install_requires = ['qtpy>2.0', 'packaging', 'diskcache', 'typer', 'click'] + _numpy_scipy()
install_suggests = {
'ipython>=5.0': 'an enhanced interactive python shell',
......@@ -51,7 +52,7 @@ install_suggests = {
'jupyter_client>=7.0.6': 'necessary to explicitly state here to fix 3js',
_PYTEST: 'testing framework required to execute unit tests',
_PYSIDE: 'solution visualization for builtin discretizations',
'ipywidgets': 'notebook GUI elements',
'ipywidgets<8,>7': 'notebook GUI elements',
'nbresuse': 'resource usage indicator for notebooks',
'torch': 'PyTorch open source machine learning framework',
'jupyter_contrib_nbextensions': 'modular collection of jupyter extensions',
......@@ -62,7 +63,7 @@ install_suggests = {
io_requires = ['pyevtk', 'xmljson', 'meshio>=4.4', 'lxml', 'gmsh']
install_suggests.update({p: 'optional File I/O support libraries' for p in io_requires})
doc_requires = ['sphinx>=5.0', 'matplotlib', _PYSIDE, 'ipyparallel>=6.2.5', 'python-slugify',
'ipywidgets', 'sphinx-qt-documentation', 'bash_kernel', 'sphinx-material',
'ipywidgets<8,>7', 'sphinx-qt-documentation', 'bash_kernel', 'sphinx-material',
'sphinxcontrib-bibtex', 'sphinx-autoapi>=1.8', 'myst-nb>=0.16'] + install_requires
ci_requires = ['check-manifest==0.48',
'check_reqs==0.2.0',
......
......@@ -10,7 +10,7 @@ dune-xt>=2021.1.3; platform_system=="Linux" and platform_machine=="x86_64"
gmsh
ipyparallel>=6.2.5
ipython>=5.0
ipywidgets
ipywidgets<8,>7
jupyter_client>=7.0.6
jupyter_contrib_nbextensions
lxml
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment