Commit bff40853 authored by René Fritze's avatar René Fritze Committed by René Fritze

[deps] mandate Qt.py version with Pyside import not neededin qtgui

parent 72ab6a23
Pipeline #48770 passed with stages
in 121 minutes and 48 seconds
0bc7dc619845aa3d3474c76880f8506767f7ea38
debcff651a903b10fe5d73e6a7941790cbcfc5b8
......@@ -45,7 +45,7 @@ stages:
numpy-git 3 6:
extends: .pytest
services:
- name: pymor/pypi-mirror_stable_py3.6:0bc7dc619845aa3d3474c76880f8506767f7ea38
- name: pymor/pypi-mirror_stable_py3.6:debcff651a903b10fe5d73e6a7941790cbcfc5b8
alias: pypi_mirror
image: pymor/testing_py3.6:b91332bb45ed1950647b572cc01b550f9009d977
......@@ -56,7 +56,7 @@ numpy-git 3 6:
oldest 3.6:
extends: .pytest
services:
- name: pymor/pypi-mirror_stable_py3.6:0bc7dc619845aa3d3474c76880f8506767f7ea38
- name: pymor/pypi-mirror_stable_py3.6:debcff651a903b10fe5d73e6a7941790cbcfc5b8
alias: pypi_mirror
image: pymor/testing_py3.6:b91332bb45ed1950647b572cc01b550f9009d977
......@@ -67,7 +67,7 @@ oldest 3.6:
minimal_cpp_demo:
extends: .pytest
services:
- name: pymor/pypi-mirror_stable_py3.6:0bc7dc619845aa3d3474c76880f8506767f7ea38
- name: pymor/pypi-mirror_stable_py3.6:debcff651a903b10fe5d73e6a7941790cbcfc5b8
alias: pypi_mirror
image: pymor/testing_py3.7:b91332bb45ed1950647b572cc01b550f9009d977
......@@ -95,7 +95,7 @@ pages:
Vanilla 3 6:
extends: .pytest
services:
- name: pymor/pypi-mirror_stable_py3.6:0bc7dc619845aa3d3474c76880f8506767f7ea38
- name: pymor/pypi-mirror_stable_py3.6:debcff651a903b10fe5d73e6a7941790cbcfc5b8
alias: pypi_mirror
image: pymor/testing_py3.6:b91332bb45ed1950647b572cc01b550f9009d977
......@@ -105,7 +105,7 @@ Vanilla 3 6:
PIP_ONLY 3 6:
extends: .pytest
services:
- name: pymor/pypi-mirror_stable_py3.6:0bc7dc619845aa3d3474c76880f8506767f7ea38
- name: pymor/pypi-mirror_stable_py3.6:debcff651a903b10fe5d73e6a7941790cbcfc5b8
alias: pypi_mirror
image: pymor/testing_py3.6:b91332bb45ed1950647b572cc01b550f9009d977
......@@ -115,7 +115,7 @@ PIP_ONLY 3 6:
NOTEBOOKS 3 6:
extends: .pytest
services:
- name: pymor/pypi-mirror_stable_py3.6:0bc7dc619845aa3d3474c76880f8506767f7ea38
- name: pymor/pypi-mirror_stable_py3.6:debcff651a903b10fe5d73e6a7941790cbcfc5b8
alias: pypi_mirror
image: pymor/testing_py3.6:b91332bb45ed1950647b572cc01b550f9009d977
......@@ -125,7 +125,7 @@ NOTEBOOKS 3 6:
MPI 3 6:
extends: .pytest
services:
- name: pymor/pypi-mirror_stable_py3.6:0bc7dc619845aa3d3474c76880f8506767f7ea38
- name: pymor/pypi-mirror_stable_py3.6:debcff651a903b10fe5d73e6a7941790cbcfc5b8
alias: pypi_mirror
image: pymor/testing_py3.6:b91332bb45ed1950647b572cc01b550f9009d977
......@@ -135,7 +135,7 @@ MPI 3 6:
Vanilla 3 7:
extends: .pytest
services:
- name: pymor/pypi-mirror_stable_py3.6:0bc7dc619845aa3d3474c76880f8506767f7ea38
- name: pymor/pypi-mirror_stable_py3.6:debcff651a903b10fe5d73e6a7941790cbcfc5b8
alias: pypi_mirror
image: pymor/testing_py3.7:b91332bb45ed1950647b572cc01b550f9009d977
......@@ -145,7 +145,7 @@ Vanilla 3 7:
PIP_ONLY 3 7:
extends: .pytest
services:
- name: pymor/pypi-mirror_stable_py3.6:0bc7dc619845aa3d3474c76880f8506767f7ea38
- name: pymor/pypi-mirror_stable_py3.6:debcff651a903b10fe5d73e6a7941790cbcfc5b8
alias: pypi_mirror
image: pymor/testing_py3.7:b91332bb45ed1950647b572cc01b550f9009d977
......@@ -155,7 +155,7 @@ PIP_ONLY 3 7:
NOTEBOOKS 3 7:
extends: .pytest
services:
- name: pymor/pypi-mirror_stable_py3.6:0bc7dc619845aa3d3474c76880f8506767f7ea38
- name: pymor/pypi-mirror_stable_py3.6:debcff651a903b10fe5d73e6a7941790cbcfc5b8
alias: pypi_mirror
image: pymor/testing_py3.7:b91332bb45ed1950647b572cc01b550f9009d977
......@@ -165,7 +165,7 @@ NOTEBOOKS 3 7:
MPI 3 7:
extends: .pytest
services:
- name: pymor/pypi-mirror_stable_py3.6:0bc7dc619845aa3d3474c76880f8506767f7ea38
- name: pymor/pypi-mirror_stable_py3.6:debcff651a903b10fe5d73e6a7941790cbcfc5b8
alias: pypi_mirror
image: pymor/testing_py3.7:b91332bb45ed1950647b572cc01b550f9009d977
......
......@@ -28,7 +28,7 @@ def setup_requires(toml=False):
numpys = [f.replace('numpy>=', 'numpy==') for f in numpys]
return numpys + other
install_requires = ['scipy>=1.1', 'Qt.py', 'packaging','diskcache', 'docopt-ng'] + setup_requires()
install_requires = ['scipy>=1.1', 'Qt.py>=1.2.4', 'packaging','diskcache', 'docopt-ng'] + setup_requires()
install_suggests = {'ipython>=5.0': 'an enhanced interactive python shell',
'ipyparallel': 'required for pymor.parallel.ipython',
'matplotlib': 'needed for error plots in demo scipts',
......
......@@ -2,7 +2,7 @@
-r requirements.txt
-r requirements-ci.txt
PySide2
Qt.py
Qt.py>=1.2.4
cython>=0.27
diskcache
docopt-ng
......
# This file is autogenerated. Edit dependencies.py instead
Qt.py
Qt.py>=1.2.4
cython>=0.27
diskcache
docopt-ng
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment