Python 3.7 Compatibility Tag

Bumps numpy & matplotlib versions so we can
use 3.7 wheels.

This tag is used by repo2docker's CI
This tag has no release notes.